Installare Windows 2003 su Proliant DL140 con controller SAS/SATA LSI

e4105a8dcdceff2738733fee6d817ae7.jpg
Dopo un giorno e mezzo passato a smadonnare in serverfarm con sbalzi di temperatura di 17° (+35 di fuori  + 18 di dentro) e nell’orecchie il rumore delle mille ventole e dei condizionatori che ti continua a ronzare anche di notte mentre dormi (fanculo stamattina mi sono portato l’Ipod dentro) sono arrivato alla soluzione! Quindi posto dei suggerimenti per chi dovesse imbattersi in questo problema.

Premesso che è noto che Windows 2003 e i DL 140 fanno a cazzotti e premesso che sicuramente ci sarà un qualcuno che ostinatamente ti dirà: CAPO “..c’è da preparare due macchine, windows 2003…” – SISTEMISTA “Che macchine sono?” – CAPO “..sono 2 proliant DL140 G3” – SISTEMISTA “uhmmm ottima scelta.. ma vafancul”. Però poi l’orgoglio umano emerge pronto a vincere la sfida con la macchina e quindi giù a lavorare.
 I server nel mio caso erano dei Proliant DL140 G3 con 2 dischi SATA HOT-PLUG da 250GB e il fatidico controller SAS/SATA embedded LSI1068 PCI-X to 8-port 3 Gb/s SAS Controller.
 
Tutti i server HP hanno un cd che si chiama SmartStart, semplice bello funzionale, accendi la macchina, inserisci il CD, ti chiede che sistema operativo vuoi installare, lo scegli, prepara l’ambiente, inserisci il CD del OS e tutto va che è una meraviglia. Tutti i server tranne la serie 100… e si perchè farlo??.. il sistemista che cazzo ci sta a fare? Quindi HP preoccupata per il nostro futuro occupazionale fornisce i DL140 di un CD di documentazione e di drivers….. cioè un cd che serve solo quando il lavoro è finito!!! Vabbè procediamo…
 
Accendo la macchina, fase di Boot, non credo ai miei occhi, hanno implementato la procedura per la creazione dell’array…bene premo F8 entro nella configurazione, pochi passi abbastanza semplici e in un attimo  tra i due dischi c’è un bel RAID 1  pronto per l’installazione. Inserisco il CD di Windows…… e dopo circa 3 minuti spunta la scritta ” Nessun disco rigido trovato”. Cazzo, che fesso che sono, gli devo dare in pasto i drivers del controller tramite floppy e premendo F6, è giusto che non mi veda i dischi!!!!
 
Per fortuna, e chi c’è passato prima di me sa che voglio dire, ho  un bel lettore Floppy USB (naturalmente i DL140 non hanno l’unità floppy e se non ne hai una esterna so’ cazzi). Apro il CD dell’HP, scarico i drivers sul floppy. Ripeto l’installazione, premo F6 legge i drivers, ma….. “Nessun disco rigido trovato”.
 
Uhmm nella testa balenano già idee strane. Ok, andiamo su internet a cercare la soluzione. Trovo tante domande non risposte e solo poche soluzioni alcune veramente strazianti, inizio delle discussioni nei forum nulla poche risposte e molto diverse tra loro. CMq provo tutte le soluzioni fattibili (cambio impostazioni nel BIOS, disabilitazione del SATA, etc etc…. nulla! Il problema non si risolve. Vado sul sito dell’HP scarico tutti i driver disponibili per i controller dei DL 140…. nulla!!! (ah proposito quando cercate i drivers cercateli sul sito in inglese, altrimenti se li cercate in italiano non ve li trova proprio e nemmeno vi avverte che c’è una versione inglese!). Le bestemmie si fanno più copiose, la macchina sta vincendo sull’uomo….uhmmm calma restiamo calmi!!!!
 
Mi siedo sfinito e fisso il monitor con quello sfondo bluetto del caizer e con quel messaggio odioso…. ci dev’essere una soluzione! Penso che alla fine mi ero concentrato esclusivamente su HP: cd di HP, Forum di HP, Drivers HP, Supporto tecnico HP… ecco la soluzione era la più facile di tutte. Talmente facile che non ti viene in mente, ma il controller SAS/SATA su questo server chi lo fabbrica?????
 
Entro nell’utility della configurazione dell’array: LSISAS1068 questo è il nome del controller. Vado sul sito dell’ LSI, cerco i drivers (questo è il link) li scarico, li metto sul floppy…… e vualà Windows vede i dischi e l’installazione può continuare.
 
Riepilogando:
1) scaricare i drivers dal sito dell’LSI 
2) creare il RAID
3) lasciare le impostazioni del BIOS come da default
4) inserire il cd di windows 2003
5) premere F6 per aggiungere i drivers del RAID
6) buona installazione 
 
 
PROVERBIO DEL GIORNO: “prima di cercare lontano, guarda che hai sotto al naso” 
 

 
 
Installare Windows 2003 su Proliant DL140 con controller SAS/SATA LSIultima modifica: 2008-05-27T13:32:58+02:00da snipho
Reposta per primo quest’articolo

2 pensieri su “Installare Windows 2003 su Proliant DL140 con controller SAS/SATA LSI

  1. cioè… per me è arabo. La cosa più difficile che so installare è pro evolution appezzottato…. cmq per quel poco che ho potuto capire sono arrivato a questa semplice intuizione: andrè, tien e’pall.
    Statt Buon!

I commenti sono chiusi.